insert MethodStatic
Insert a new instance of the Relationship.
insert<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): string
@returns The Id of the inserted Relationship.
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel that will contain the relationship |
sourceId | string | The sourceId of the relationship, that is, the driver element |
targetId | string | The targetId of the relationship, that is, the driven element |
Returns - string
The Id of the inserted Relationship.
Defined in
- core/backend/src/Relationship.ts Line 86
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.