create MethodStatic
Create an instance of the Relationship.
create<T extends ElementRefersToElements>(iModel: IModelDb, sourceId: string, targetId: string): T
@returns an instance of the specified class.
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel that will contain the relationship |
sourceId | string | The sourceId of the relationship, that is, the driver element |
targetId | string | The targetId of the relationship, that is, the driven element |
Returns - T
an instance of the specified class.
Defined in
- core/backend/src/Relationship.ts Line 77
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.