NativeHost Class
Backend for desktop/mobile native applications
Methods
Name | Description | |
---|---|---|
checkInternetConnectivity(): InternetConnectivityStatus Static | get current value of internet connectivity | |
notifyNativeFrontend<T extends "notifyInternetConnectivityChanged">(methodName: T, ...args: Parameters<>): void Static | Send a notification to the NativeApp connected to this NativeHost. | |
shutdown(): Promise<void> Static | Shutdown native app backend. | |
startup(opt?: NativeHostOpts): Promise<void> Static | Start the backend of a native app. |
Properties
Name | Type | Description | |
---|---|---|---|
applicationName Accessor Static ReadOnly | string | ||
appSettingsCacheDir Accessor Static ReadOnly | string | Get the local cache folder for application settings | |
isValid Accessor Static ReadOnly | boolean | ||
onInternetConnectivityChanged Static Readonly | BeEvent<(status: InternetConnectivityStatus) => void> | Event called when the internet connectivity changes, if known. | |
settingsStore Accessor Static ReadOnly | NativeAppStorage | Get the settings store for this NativeHost. |
Defined in
- core/backend/src/NativeHost.ts Line 133
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.