handle MethodStatic
Establish a handler for an Ipc channel to receive Frontend.invoke calls
handle(channel: string, handler: (...args: any[]) => Promise<any>): RemoveFunction
@note returns A function to call to remove the handler.
Parameter | Type | Description |
---|---|---|
channel | string | The name of the channel for this handler. |
handler | (...args: any[]) => Promise<any> | A function that supplies the implementation for channel |
Returns - RemoveFunction
Defined in
- core/backend/src/IpcHost.ts Line 69
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.