channelName
GetterAbstract ReadOnly
All subclasses must implement this method to specify their channel name.
Channel names are the key that connects Handlers and senders. The channel name of IpcHandlers must exactly match the name used by senders.
By convention, channel names should be prefixed by a namespace (e.g. ${appName}/
)
unique enough to disambiguate them from channels for other apps that may be running in the same processes.
channelName: string
Returns - string
Defined in
- core/backend/src/IpcHost.ts Line 154
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.