reverseTxns Method
Reverse (undo) the most recent operation(s) to this IModelDb.
reverseTxns(numOperations: number): IModelStatus
@note If there are any outstanding uncommitted changes, they are reversed.
@note The term "operation" is used rather than Txn, since multiple Txns can be grouped together via beginMultiTxnOperation. So, even if numOperations is 1, multiple Txns may be reversed if they were grouped together when they were made.
@note If numOperations is too large only the operations are reversible are reversed.
Returns - IModelStatus
Defined in
- core/backend/src/TxnManager.ts Line 518
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.