reinstateTxn Method
Reinstate the most recently reversed transaction. Since at any time multiple transactions can be reversed, it may take multiple calls to this method to reinstate all reversed operations.
reinstateTxn(): IModelStatus
@returns Success if a reversed transaction was reinstated, error status otherwise.
@note If there are any outstanding uncommitted changes, they are canceled before the Txn is reinstated.
Returns - IModelStatus
Success if a reversed transaction was reinstated, error status otherwise.
Defined in
- core/backend/src/TxnManager.ts Line 546
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.