createCode MethodStatic
Create a Code for a SubCategory given a name that is meant to be unique within the scope of the specified parent Category.
createCode(iModel: IModelDb, parentCategoryId: string, codeValue: string): Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModel |
parentCategoryId | string | The Id of the parent Category that owns the SubCategory and provides the scope for its name. |
codeValue | string | The name of the SubCategory |
Returns - Code
Defined in
- core/backend/src/Category.ts Line 55
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.