createClassViews Method
Creates or updates views in the iModel to permit visualizing the EC content as ECClasses and ECProperties rather than raw database tables and columns. This can be helpful when debugging the EC data, especially when the raw tables make use of shared columns or spread data across multiple tables.
createClassViews(): void
@throws IModelError if view creation failed.
@note The views are strictly intended for developers and debugging purposes only - they should not be used in application code.
Returns - void
Defined in
- core/backend/src/IModelDb.ts Line 3415
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.