createFrom MethodStatic
Create a local Snapshot iModel file, using this iModel as a seed or starting point. Snapshots are not synchronized with iModelHub, so do not have a change timeline. @note: A snapshot cannot be modified after close is called.
createFrom(iModelDb: IModelDb, snapshotFile: string, options?: CreateSnapshotIModelProps): SnapshotDb
@returns A writeable SnapshotDb
@see Snapshot iModels
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The snapshot will be initialized from the current contents of this iModelDb |
snapshotFile | string | The file that will contain the new iModel snapshot |
options | CreateSnapshotIModelProps | Optional properties that determine how the snapshot iModel is created. |
Returns - SnapshotDb
A writeable SnapshotDb
Defined in
- core/backend/src/IModelDb.ts Line 3232
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.