createEmpty MethodStatic
Create an empty local Snapshot iModel file. Snapshots are not synchronized with iModelHub, so do not have a change timeline. @note: A snapshot cannot be modified after close is called.
createEmpty(filePath: string, options: CreateEmptySnapshotIModelProps): SnapshotDb
@returns A writeable SnapshotDb
@see Snapshot iModels
Parameter | Type | Description |
---|---|---|
filePath | string | The file that will contain the new iModel snapshot |
options | CreateEmptySnapshotIModelProps | The parameters that define the new iModel snapshot |
Returns - SnapshotDb
A writeable SnapshotDb
Defined in
- core/backend/src/IModelDb.ts Line 3211
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.