PushChangesArgs Interface
Parameters for pushing changesets to iModelHub
Extends
Properties
Name | Type | Description | |
---|---|---|---|
description | string | A description of the changes. | |
mergeRetryCount | number | undefined | number of times to retry pull/merge if other users are pushing at the same time. | |
mergeRetryDelay | BeDuration | undefined | delay to wait between pull/merge retry attempts. | |
pushRetryCount | number | undefined | the number of time to attempt to retry to push the changeset upon failure. | |
pushRetryDelay | BeDuration | undefined | The delay to wait between retry attempts on failed pushes. | |
retainLocks | "true" | undefined | if present, the locks are retained after the operation. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken Readonly | string | undefined | TokenArg | If present, the access token for the requested operation. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.