saveSettingDictionary Method
Save a SettingDictionary
in this iModel that will be loaded into settings every time this iModel is opened in future sessions.
saveSettingDictionary(name: string, dict: SettingsContainer): void
@note All saved SettingDictionary
s are loaded into settings every time an iModel is opened.
Parameter | Type | Description |
---|---|---|
name | string | The name for the SettingDictionary. If a dictionary by that name already exists in the iModel, its value is replaced. |
dict | SettingsContainer | The SettingDictionary object to stringify and save. |
Returns - void
Defined in
- core/backend/src/IModelDb.ts Line 1390
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.