queryViewDefinitionProps Method
Query for the array of ViewDefinitionProps of the specified class and matching the specified IsPrivate setting.
queryViewDefinitionProps(className: string"BisCore.ViewDefinition", limit: numberIModelDb.defaultLimit, offset: number0, wantPrivate: booleanfalse): ViewDefinitionProps[]
Parameter | Type | Description |
---|---|---|
className | string | Query for view definitions of this class. |
limit | number | |
offset | number | |
wantPrivate | boolean | If true, include private view definitions. |
Returns - ViewDefinitionProps[]
Defined in
- core/backend/src/IModelDb.ts Line 2304
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.