queryExtents Method
For each specified GeometricModel, attempts to obtain the union of the volumes of all geometric elements within that model.
queryExtents(ids: string | string[]): Promise<ModelExtentsProps[]>
@returns An array of results, one per supplied Id, in the order in which the Ids were supplied. If the extents could not be obtained, the
corresponding results entry's extents
will be a "null" range (See: Range3d.isNull) and its status
will indicate
why the extents could not be obtained (e.g., because the Id did not identify a GeometricModel).
@see IModelDb.Models.queryRange to obtain the union of all of the models' extents.
Parameter | Type | Description |
---|---|---|
ids | string | string[] | The Id or Ids of the GeometricModels for which to obtain the extents. |
Returns - Promise<ModelExtentsProps[]>
An array of results, one per supplied Id, in the order in which the Ids were supplied. If the extents could not be obtained, the
corresponding results entry's extents
will be a "null" range (See: Range3d.isNull) and its status
will indicate
why the extents could not be obtained (e.g., because the Id did not identify a GeometricModel).
Defined in
- core/backend/src/IModelDb.ts Line 1686
Last Updated: 14 November, 2024