CheckpointProps Interface
Properties of a checkpoint
Extends
Properties
Name | Type | Description | |
---|---|---|---|
allowPreceding Readonly | boolean | undefined | If true, then the latest successful v2 checkpoint at or before the provided changeset will be returned when calling queryV2Checkpoint. | |
changeset Readonly | ChangesetIdWithIndex | changeset for the checkpoint | |
expectV2 Readonly | boolean | undefined | ||
iModelId Readonly | string | Id of the iModel | |
iTwinId Readonly | string | iTwin that the iModel belongs to | |
reattachSafetySeconds Readonly | number | undefined | The number of seconds before the current token expires to attempt to reacquire a new token. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken Readonly Inherited | string | undefined | TokenArg | If present, the access token for the requested operation. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.