ChangeInstanceKey Interface
Represents a change (insertion, deletion, or modification) to a single EC instance made in a local BriefcaseDb.
@see queryLocalChanges to iterate all of the changed instances.
Properties
Name | Type | Description | |
---|---|---|---|
changeType | "deleted" | "inserted" | "updated" | The type of change. | |
classFullName | string | Fully-qualified class name of the instance. | |
id | string | ECInstanceId of the instance. |
Defined in
- core/backend/src/TxnManager.ts Line 66
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.