ExportPartGraphicsOptions Interface
Parameters for IModelDb.exportPartGraphics
Properties
Name | Type | Description | |
---|---|---|---|
angleTol | number | undefined | Max angle difference in radians for approximated face, see StrokeOptions. | |
chordTol | number | undefined | Max distance from a face to the original geometry, see StrokeOptions. | |
decimationTol | number | undefined | Max distance between mesh vertices for them to be collapsed. | |
displayProps | ExportPartDisplayInfo | The base display properties to use for generating the graphics. | |
elementId | string | The ID for the source GeometryPart | |
maxEdgeLength | number | undefined | Max length of any edge in generated faces, see StrokeOptions | |
minBRepFeatureSize | number | undefined | BRep features with bounding boxes smaller than this size will not generate graphics. | |
minLineStyleComponentSize | number | undefined | The longest dimension of a line style's largest component must be at least this size in order for | |
onPartGraphics | ExportPartFunction | A function to call for each unique color and texture combination. | |
onPartLineGraphics | ExportPartLinesFunction | undefined | An optional function to call if line graphics are desired. |
Defined in
- core/backend/src/ExportGraphics.ts Line 222
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.