createCode MethodStatic
Create a Code for a LineStyle definition given a name that is meant to be unique within the scope of the specified model.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code
@returns A LineStyle Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModel |
scopeModelId | string | The Id of the DefinitionModel that contains the LineStyle and provides the scope for its name. |
codeValue | string | The name of the LineStyle |
Returns - Code
A LineStyle Code
Defined in
- core/backend/src/Element.ts Line 1496
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.