ChannelControl Namespace
Variable
Name | Description |
---|---|
ChannelControl.sharedChannelName | the name of the special "shared" channel holding information that is editable by any application. |
Defined in
ChannelControl Interface
Controls which channels of an iModel are permitted for write operations. An implementation of this interface is available via channels.
@see Working With Channels for details
Methods
Name | Description | |
---|---|---|
addAllowedChannel(channelKey: string): void | Add a new channel to the list of allowed channels of the IModelDb for this session. | |
getChannelKey(elementId: string): string | Get the channelKey of the channel for an element by ElementId. | |
insertChannelSubject(args: { channelKey: string, description?: string, parentSubjectId?: string, subjectName: string }): string | Insert a new Subject element that is a Channel Root in this iModel. | |
makeChannelRoot(args: { channelKey: string, elementId: string }): void | Make an existing element a new Channel root. | |
queryChannelRoot(channelKey: string): undefined | string | Queries for the element Id acting as the ChannelRoot for a given channelKey, if any | |
removeAllowedChannel(channelKey: string): void | Remove a channel from the list of allowed channels of the IModelDb for this session. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.