LineStyleDefinition.SymbolProps Interface

Identifies a symbol and its location and orientation relative to a stroke pattern

Properties

Name Type Description
angle number | undefined Symbol rotation in radians  
mod1 LineStyleDefinition.SymbolOptions | undefined Must set location for symbol as default value is LineStyleDefinition.SymbolOptions.None  
strokeNum number | undefined The 0 based stroke index for base stroke pattern LineStyleDefinition.ComponentType.StrokePattern component  
symId number The file property id of the symbol component, assumed to be LineStyleDefinition.ComponentType.PointSymbol if symType is undefined.  
symType LineStyleDefinition.ComponentType | undefined The component type, leave undefined if symId is a LineStyleDefinition.ComponentType.PointSymbol  
xOffset number | undefined Symbol x offset distance in meters  
yOffset number | undefined Symbol y offset distance in meters  

Defined in

Last Updated: 14 November, 2024