insert MethodStatic
Deprecated in 4.0 use makeChannelRoot. This method does not enforce the rule that channels may not nest and is therefore dangerous.
Insert a ChannelRootAspect on the specified element.
insert(iModel: IModelDb, ownerId: string, channelName: string): void
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | |
ownerId | string | |
channelName | string |
Returns - void
Defined in
- core/backend/src/ElementAspect.ts Line 135
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.