ChangeMetaData Interface
Record meta data for the change.
Properties
Name | Type | Description | |
---|---|---|---|
changeIndexes | number[] | list of change index making up this change (one per table) | |
classFullName | string | undefined | full name of the class of this EC change | |
fallbackClassId | string | undefined | if classId for the change was not found in db then fallback class for the table | |
op | SqliteChangeOp | sqlite operation that caused the change | |
stage | SqliteValueStage | version of the value read from sqlite change | |
tables | string[] | list of tables making up this EC change |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.