setExternalSourceAspect Method
Adds or updates the external source aspect for the given source item onto the related element - this function is rarely needed, because updateIModel automatically inserts or updates ExternalSourceAspects for the elements that it processes.
setExternalSourceAspect(element: ElementProps, itemState: ItemState, sourceItem: SourceItem): IModelStatus
Parameter | Type | Description |
---|---|---|
element | ElementProps | The element to attach the ExternalSourceAspect |
itemState | ItemState | The state of the source item |
sourceItem | SourceItem | Defines the source item |
Returns - IModelStatus
Defined in
- Synchronizer.ts Line 493
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.