TreeNodeRendererProps Interface
Properties for TreeNodeRenderer.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
checkboxRenderer | (props: CheckboxRendererProps) => React.ReactNode | undefined | Callback to render custom checkbox. | |
children | React.ReactNode | undefined | Child components to render inside the node. | |
descriptionEnabled | boolean | undefined | Specifies whether to show descriptions or not. | |
imageLoader | ITreeImageLoader | undefined | Image loader for node icons. | |
node | TreeModelNode | Tree node to render. | |
nodeEditorRenderer | TreeNodeEditorRenderer | undefined | Callback to render custom node editor when node is in editing mode. | |
nodeHighlightProps | HighlightableTreeNodeProps | undefined | Properties used to highlight matches when tree is filtered. | |
onContextMenu | (e: React.MouseEvent<Element, MouseEvent>, node: TreeModelNode) => void | undefined | Callback that is invoked when context menu should be opened. | |
treeActions | TreeActions | Action handler. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.