TreeNodeContentProps Interface
Deprecated in 4.17.0. Use React.ComponentProps<typeof TreeNodeContent>
Properties for TreeNodeContent component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
highlightProps | HighlightableTreeNodeProps | undefined | Props for highlighting label parts that matches filter when tree is filtered. | |
node | TreeModelNode | Tree node to render label for. | |
nodeEditorRenderer | TreeNodeEditorRenderer | undefined | Callback to render custom node editor when node is in editing mode. | |
onLabelRendered | (node: TreeModelNode) => void | undefined | Callback used to detect when label is rendered. | |
showDescription | boolean | undefined | Flag that specified whether the description should be shown or not. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.