moveNode Method

Transfers node along with its children to a new location. Fails if destination has undefined child count.

moveNode(sourceNodeId: string, targetParentId: string, targetIndex: number): boolean

@returns true on success, false otherwise.

Parameter Type Description
sourceNodeId string Node that is being moved.
targetParentId string Node that will receive a new child.
targetIndex number Insertion location among target's current children.

Returns - boolean

true on success, false otherwise.

Defined in

Last Updated: 14 November, 2024