PopupItemProps Interface
Deprecated in 4.16.0. Props of deprecated PopupItem component.
Properties of PopupItem component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
hideIndicator | boolean | undefined | Describes if expandable item triangle indicator should be hidden. | |
keepContentsMounted | boolean | undefined | If true the popup panel is mounted once and unmounted when button is unmounted. | |
panel | React.ReactNode | undefined | Panel of the toolbar. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
addGroupSeparator | boolean | undefined | ToolbarButtonItemProps | If true add a gap before button. |
badge | React.ReactNode | undefined | ToolbarButtonItemProps | A badge to draw. |
className | string | undefined | ToolbarButtonItemProps | Custom CSS class name |
groupPriority | number | undefined | ToolbarButtonItemProps | value added to DOM element as a data attribute |
icon | React.ReactNode | undefined | ToolbarButtonItemProps | button icon. |
isActive | boolean | undefined | ToolbarButtonItemProps | Describes if item is active. |
isDisabled | boolean | undefined | ToolbarButtonItemProps | Describes if the item is disabled. |
itemId | string | undefined | ToolbarButtonItemProps | Optional unique identifier for item. |
itemPriority | number | undefined | ToolbarButtonItemProps | value added to DOM element as a data attribute, shows 0 is undefined |
onClick | () => void | undefined | ToolbarButtonItemProps | Function called when the item is clicked. |
onKeyDown | (e: React.KeyboardEvent<Element>) => void | undefined | ToolbarButtonItemProps | Function called when a key is pressed. |
providerId | string | undefined | ToolbarButtonItemProps | value added to DOM element as a data attribute to hold name of items provider. |
style | React.CSSProperties | undefined | ToolbarButtonItemProps | Custom CSS style properties |
title | string | ToolbarButtonItemProps | Title for the item. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.