usePropertyGridModelSource Function
Deprecated in 4.9.0. Use useTrackedPropertyGridModelSource
instead.
Custom hook that creates a PropertyGridModelSource and subscribes it to data updates from the data provider.
usePropertyGridModelSource(props: { dataProvider: IPropertyDataProvider }): PropertyGridModelSource
@throws if/when IPropertyDataProvider.getData()
promise is rejected. The error is thrown in the React's render loop, so it can be caught using an error boundary.
Parameter | Type | Description |
---|---|---|
props | { dataProvider: IPropertyDataProvider } |
Returns - PropertyGridModelSource
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.