usePropertyData Function
Custom hook that gets PropertyData from given IPropertyDataProvider and subscribes to further data changes.
usePropertyData(props: { dataProvider: IPropertyDataProvider }): { inProgress: boolean, value: undefined | PropertyData }
@throws if/when IPropertyDataProvider.getData()
promise is rejected. The error is thrown in the React's render loop, so it can be caught using an error boundary.
Parameter | Type | Description |
---|---|---|
props | { dataProvider: IPropertyDataProvider } |
Returns - { inProgress: boolean, value: undefined | PropertyData }
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.