PropertyDataFilterResult Interface
Data structure for storing IPropertyDataFilterer matching results
Properties
Name | Type | Description | |
---|---|---|---|
filteredTypes | FilteredType[] | undefined | Indicates what item types were matched. | |
matchesCount | number | undefined | Indicates how many times filter was matched in the provided item. | |
matchesFilter | boolean | Indicates whether provided item matched filter | |
shouldExpandNodeParents | boolean | undefined | Indicates whether parents of node should be expanded up to this match node. | |
shouldForceIncludeDescendants | boolean | undefined | Indicates whether descendants nodes should be forcefully included in filtered results. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.