PropertyFilterBuilderRule Interface
Data structure that describes PropertyFilterBuilder component single rule.
Properties
Name | Type | Description | |
---|---|---|---|
string | undefined | Error message of this rule. | ||
groupId | string | Id of rule group that this rule is nested in. | |
id | string | Id of this rule. | |
operator | PropertyFilterBuilderRuleOperator | undefined | Operator that should be used to compare property value. | |
property | PropertyDescription | undefined | Property used in this rule. | |
value | PropertyValue | undefined | Value that property should be compared to. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.