EditorContainerProps Interface
Deprecated in 4.17.0. Use React.ComponentProps<typeof EditorContainer>
EditorContainer React component properties
Extends
Properties
Name | Type | Description | |
---|---|---|---|
onCancel | () => void | Handler for cancel | |
onCommit | (args: PropertyUpdatedArgs) => void | Handler for commit | |
propertyRecord | PropertyRecord | The property being updated. | |
setFocus | boolean | undefined | Indicates whether the Property Editor should set focus | |
title | string | undefined | Tooltip text |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.