TableNonPrimitiveValueRendererProps Interface
Properties for TableNonPrimitiveValueRenderer React component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
buttonLabel | string | Text that will be rendered in the table cell, in other words - Property value | |
dialogContents | React.ReactNode | Contents of the dialog. | |
dialogTitle | string | Title of the dialog that shows property in more detail. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onDialogOpen | (dialogState: PropertyDialogState) => void | undefined | SharedTableNonPrimitiveValueRendererProps | Callback to request for dialog to be opened. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.