FilteringInputProps Interface
FilteringInput React Component properties
Extends
Properties
Name | Type | Description | |
---|---|---|---|
autoFocus | boolean | undefined | Specify that the element should automatically get focus | |
onFilterCancel | () => void | Filtering is canceled while still in progress | |
onFilterClear | () => void | Filtering is cleared after everything's loaded | |
onFilterStart | (searchText: string) => void | Filtering should start | |
resultSelectorProps | ResultSelectorProps | undefined | ResultSelector React Component properties. | |
status | FilteringInputStatus | Tells the component what is the status of filtering. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.