renderFavorites Method
renderFavorites(propertyData, orientation?)
Allow creating an HTMLElement containing the <FavoritePropertyList />
component so it can be added outside of a React component (showCard
is the main expected use)
renderFavorites(propertyData: PropertyData, orientation?: Orientation): string | HTMLElement
@returns a div
HTMLElement with the <FavoritePropertyList />
rendered within it.
Parameter | Type | Description |
---|---|---|
propertyData | PropertyData | PropertyData containing Favorite records to display. |
orientation | Orientation | Orientation of the items |
Returns - string | HTMLElement
a div
HTMLElement with the <FavoritePropertyList />
rendered within it.
renderFavorites(propertyData, orientation?, _createRoot?)
Deprecated in 5.0.0. Use the overload without createRoot
parameter instead.
Allow creating an HTMLElement containing the <FavoritePropertyList />
component so it can be added outside of a React component (showCard
is the main expected use)
renderFavorites(propertyData: PropertyData, orientation?: Orientation, _createRoot?: CreateRoot): string | HTMLElement
@note Previously when using React18, in order to remove the ReactDOM.render
warning you needed to provide the createRoot
function. This function is no longer used.
@returns a div
HTMLElement with the <FavoritePropertyList />
rendered within it.
Parameter | Type | Description |
---|---|---|
propertyData | PropertyData | PropertyData containing Favorite records to display. |
orientation | Orientation | Orientation of the items |
_createRoot | CreateRoot |
Returns - string | HTMLElement
a div
HTMLElement with the <FavoritePropertyList />
rendered within it.
Defined in
Last Updated: 17 December, 2024