BrowserAuthorizationClientConfiguration Interface
Extends
Properties
Name | Type | Description | |
---|---|---|---|
authority Readonly | string | undefined | The URL of the OIDC/OAuth2 provider. | |
clientId Readonly | string | The unique client id registered through the issuing authority. | |
noSilentSignInOnAppStartup Readonly | boolean | undefined | if true, do NOT attempt a silent signIn on startup of the application | |
postSignoutRedirectUri Readonly | string | undefined | The URL passed in the signout request, to which the authority will redirect the browser after the user has been signed out. | |
redirectUri Readonly | string | The URL passed in the authorization request, to which the authority will redirect the browser after the user grants/denies access | |
responseMode Readonly | "query" | "fragment" | ||
responseType Readonly | string | undefined | The mechanism (or authentication flow) used to acquire auth information from the user through the authority | |
scope Readonly | string | A space-delimited collection of individual access claims specified by the authority. | |
silentRedirectUri Readonly | string | undefined | The redirect URL used for silent sign in and renew. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
prompt | string | undefined | BrowserAuthorizationClientRequestOptions | The required action demanded of the user before the authentication request can succeed |
Defined in
- types.ts Line 28
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.