WidgetConfig Interface
Configuration from which a widget is created.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
labelKey Readonly | string | undefined | If set, it is used to define a key that is used to look up a localized string. | |
tooltipKey Readonly | string | undefined | If set, it is used to define a key that is used to look up a localized string. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
allowedPanels Readonly | ReadonlyArray<StagePanelLocation> | undefined | Widget | Stage panels to which this widget can be docked. |
badge Readonly | BadgeType | undefined | Widget | Specifies the kind of badge, if any, to be rendered. |
badgeKind Readonly | BadgeKind | undefined | Widget | Specifies the kind of badge, if any, to be rendered. |
canFloat Readonly | boolean | CanFloatWidgetOptions | Widget | Set to false to disable floating of a widget. |
canPopout Readonly | boolean | undefined | Widget | Describes if the widget can be popped out to a separate window. |
content Readonly | React.ReactNode | undefined | Widget | Content of the Widget. |
defaultState Readonly | WidgetState | undefined | Widget | Defaults to Floating if widget is not allowed to dock to any panels. |
icon Readonly | IconSpec | undefined | Widget | |
iconNode Readonly | React.ReactNode | undefined | Widget | Icon to use for the widget. |
id Readonly | string | Widget | |
label Readonly | string | ConditionalStringValue | Widget | |
layouts Readonly | WidgetLayouts | undefined | Widget | Describes layout specific configuration of a widget. |
priority Readonly | number | undefined | Widget | |
tooltip Readonly | string | ConditionalStringValue | Widget |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.