NavigationWidgetComposerProps Interface

Deprecated  in 4.17.0. Use React.ComponentProps<typeof NavigationWidgetComposer>

Properties for the NavigationWidgetComposer React components

Extends

Properties

Name Type Description
hideNavigationAid boolean | undefined If true no navigation aid will be shown.  
horizontalToolbar React.ReactNode | undefined Optional horizontal toolbar  
navigationAidHost React.ReactNode | undefined Optional navigation aid to override the default NavigationAidHost.  
verticalToolbar React.ReactNode | undefined Optional vertical toolbar  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 14 November, 2024