useConditionalValue Function
Hook that allows to get a value that depends on some sync UI events.
useConditionalValue<T>(getValue: () => T, eventIds: string[]): T
@note This can be used as a replacement for a deprecated ($@itwin/core-react#ConditionalIconItem$refLinkSource=appui-react/ui/appui-react/src/appui-react/hooks/useConditionalValue.tsx@16).
Parameter | Type | Description |
---|---|---|
getValue | () => T | |
eventIds | string[] |
Returns - T
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.