showKeyinPalette MethodStatic
Show the Key-in Palette to display key-in from all registered Tools.
showKeyinPalette(keyinEntries: KeyinEntry[], htmlElement?: HTMLElement): boolean
@returns true if the Command Palette was displayed, false if it could not be displayed.
Parameter | Type | Description |
---|---|---|
keyinEntries | KeyinEntry[] | A list of KeyinEntry to display in the palette. These can be gathered and filtered from iModelApp.tools.getToolList() |
htmlElement | HTMLElement | The HTMLElement that anchors the Popup. If undefined, the location is relative to the overall window. |
Returns - boolean
true if the Command Palette was displayed, false if it could not be displayed.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.