getIcon MethodStatic
Get JSX element that defines an icon. If iconSpec is a string, then a web-font icon class is used otherwise a ReactNode holding an SVG icon is assumed.
getIcon(iconSpec: ConditionalStringValue | React.ReactNode): undefined | React.ReactElement<any, string | React.JSXElementConstructor<any>>
Parameter | Type | Description |
---|---|---|
iconSpec | ConditionalStringValue | React.ReactNode |
Returns - undefined | React.ReactElement<any, string | React.JSXElementConstructor
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.