FrameworkVisibility Interface

visibility interface

Methods

Name Description
handleContentMouseMove(_event?: React.MouseEvent<HTMLElement, MouseEvent>): void Handler for when the mouse moves over the content area  
handleFrontstageReady(): void Handler for when a Frontstage is ready  
handleWidgetMouseEnter(_event?: React.MouseEvent<HTMLElement, MouseEvent>): void Handler for when the mouse enters a widget  
showUiAndCancelTimer(): void Shows the Ui and cancels the inactivity timer  
showUiAndResetTimer(): void Shows the Ui and resets the inactivity timer  

Properties

Name Type Description
autoHideUi boolean When true, the UI automatically hides after a specified period of inactivity, defined by inactivityTime.  
inactivityTime number Determines the amount of inactivity time in ms before the UI is hidden if autoHideUi is enabled.  
isUiVisible boolean Determines if the Ui is visible  
showHideFooter boolean Determines whether the status bar is shown and hidden.  
showHidePanels boolean Determines whether the widget panels are shown and hidden.  
snapWidgetOpacity boolean Determines whether the opacity of a toolbar should change immediately when the mouse gets close.  
useProximityOpacity boolean Determines whether the proximity of the mouse should alter the opacity of a toolbar. Deprecated  

Defined in

Last Updated: 14 November, 2024