getWidgets MethodStatic
getWidgets(stageId, stageUsage)
Returns registered widgets that match the specified frontstage id and usage.
getWidgets(stageId: string, stageUsage: string): ReadonlyArray<ProviderItem<Widget>>
@note Items registered in UiItemsManager
of @itwin/appui-abstract
are not returned by this method.
@note Items returned by provideWidgets are not returned by this method.
Parameter | Type | Description |
---|---|---|
stageId | string | |
stageUsage | string |
Returns - ReadonlyArray<ProviderItem<Widget>>
getWidgets(stageId, stageUsage, location, section?)
Returns registered widgets configured for the standard layout that match the specified frontstage id and usage.
getWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection): ReadonlyArray<ProviderItem<Widget>>
@note Items registered in UiItemsManager
of @itwin/appui-abstract
are returned by this method.
@note Items returned by provideWidgets are returned by this method.
Parameter | Type | Description |
---|---|---|
stageId | string | |
stageUsage | string | |
location | StagePanelLocation | |
section | StagePanelSection |
Returns - ReadonlyArray<ProviderItem<Widget>>
Defined in
Last Updated: 14 March, 2025