getToolbarButtonItems MethodStatic
Returns registered toolbar items configured for the standard layout that match the specified frontstage id and usage.
getToolbarButtonItems(stageId: string, stageUsage: string, usage: ToolbarUsage, orientation: ToolbarOrientation): ReadonlyArray<ProviderItem<ToolbarItem>>
@note Items registered in UiItemsManager
of @itwin/appui-abstract
are returned by this method.
@note Items returned by provideToolbarItems are returned by this method.
Parameter | Type | Description |
---|---|---|
stageId | string | |
stageUsage | string | |
usage | ToolbarUsage | |
orientation | ToolbarOrientation |
Returns - ReadonlyArray<ProviderItem<ToolbarItem>>
Defined in
Last Updated: 14 March, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.