getStatusBarItems MethodStatic

Called when the application is populating the statusbar so that any registered UiItemsProvider can add status fields

getStatusBarItems(stageId: string, stageUsage: string): ReadonlyArray<ProviderItem<StatusBarItem>>

@returns An array of CommonStatusBarItem that will be used to create controls for the status bar.

Parameter Type Description
stageId string a string identifier of the active stage.
stageUsage string the StageUsage of the active stage.

Returns - ReadonlyArray<ProviderItem<StatusBarItem>>

An array of CommonStatusBarItem that will be used to create controls for the status bar.

Defined in

Last Updated: 14 November, 2024