StatusBarLabelIndicatorProps Interface

Deprecated  in 4.14.0. Props of deprecated component StatusBarLabelIndicator.

Properties of StatusBarLabelIndicator component.

Extends

Properties

Name Type Description
iconSpec IconSpec | undefined Specification of an icon.  
label string | undefined Indicator label.  
labelSide StatusBarLabelSide | undefined Side to display label.  

Inherited properties

Name Type Inherited from Description
className string | undefined Omit Custom CSS class name
defaultIsOpen boolean | undefined Omit Default state of an indicator popup.
itemId string | undefined Omit Optional unique identifier for item.
onClick () => void | undefined Omit Function called when indicator is clicked.
popup React.ReactNode | undefined Omit Content to display in a popup when indicator is clicked.
style React.CSSProperties | undefined Omit Custom CSS style properties
title string | undefined Omit Title of an indicator.

Defined in

Last Updated: 14 November, 2024