StatusBarComposerProps Interface
Deprecated in 4.17.0. Use React.ComponentProps<typeof StatusBarComposer>
Properties for the StatusBarComposer React components
Extends
Properties
Name | Type | Description | |
---|---|---|---|
centerClassName | string | undefined | CSS class name override for the center section | |
items | StatusBarItem[] | Status Bar items | |
leftClassName | string | undefined | CSS class name override for the left section | |
mainClassName | string | undefined | CSS class name override for the overall Status Bar | |
rightClassName | string | undefined | CSS class name override for the right section |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.