CommonStatusBarItem Interface

Describes the data needed to insert a button into the status bar.

Properties

Name Type Description
badge Readonly BadgeType | undefined Describes badge. Deprecated  
badgeKind Readonly BadgeKind | undefined Specifies the kind of badge, if any, to be rendered.  
id Readonly string Required unique id of the item.  
isDisabled Readonly boolean | ConditionalBooleanValue Describes if the item is enabled or disabled.  
isHidden Readonly boolean | ConditionalBooleanValue Describes if the item is visible or hidden.  
itemPriority Readonly number Priority within a section (recommend using values 1 through 100).  
section Readonly StatusBarSection status bar section  

Defined in

Last Updated: 14 November, 2024