SessionStateActionsProps Interface
Deprecated in 4.15.0. Use your preferred state management library instead.
An interface that allows redux connected object to dispatch changes to the SessionState reducer.
Properties
Name | Type | Description | |
---|---|---|---|
setActiveIModelId | (iModelId: string) => ActionWithPayload<SetActiveIModelId, string> | ||
setAvailableSelectionScopes | (availableSelectionScopes: PresentationSelectionScope[]) => ActionWithPayload<SetAvailableSelectionScopes, DeepReadonlyArray<PresentationSelectionScope>> | ||
setDefaultIModelViewportControlId | (iModelViewportControlId: string) => ActionWithPayload<SetDefaultIModelViewportControlId, string> | ||
setDefaultViewId | (viewId: string) => ActionWithPayload<SetDefaultViewId, string> | ||
setDefaultViewState | (viewState: any) => ActionWithPayload<SetDefaultViewState, any> | ||
setIModelConnection | (iModelConnection: any) => ActionWithPayload<SetIModelConnection, any> | ||
setNumItemsSelected | (numSelected: number) => ActionWithPayload<SetNumItemsSelected, number> | ||
setSelectionScope | (activeSelectionScope: string) => ActionWithPayload<SetSelectionScope, string> | ||
updateCursorMenu | (cursorMenuData: CursorMenuData | CursorMenuPayload) => ActionWithPayload<UpdateCursorMenu, DeepReadonlyObject<CursorMenuData> | DeepReadonlyObject<CursorMenuPayload>> |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.